dolezel.net

Co není v hlavě, je v blogu...

Problém s aktualizací IMAP složek na Exchange Serveru 2010 – vyřešeno

Kolegové, kteří používají IMAP4 připojení, objevili problém, ke kterému dojde po migraci schránek z Exchange 2007 na Exchange 2010. Microsoft 1. února chybu potvrdil, údajně pracuje na hotfixu, ale ten dnes odpoledne nebyl dostupný. Chyba se projevuje tak, že se v IMAP složce neobjevuje nová pošta. Přes IMAP se přihlašují hlavně linux kolegové, takže níže uvedené obejití problému je fakt tristní.

Jediným způsobem, jak se této chyby zbavit, je následující postup:

  1. Přihlásit se na terminálový server, nakonfigurovat si Outlook 2007
  2. Přesvědčit se, že Outlook 2007 je nakonfigurován v režimu BEZ použití lokálních cache souborů (jinak budou další kroky trvat zbytečně dlouho).
  3. Vytvořit si ve složce, která se přes IMAP nesynchronizuje dobře, libovolnou podsložku a do ní PŘESUNOUT veškerý obsah té nefukční složky.
  4. PŘESUNOUT obsah pomocné podsložky ZPĚT.
  5. Zopakovat kroky 3-4 pro všechny složky, v nichž se pomocí IMAP protokolu nezobrazují nové e-maily.
  6. V poštovním IMAP programu (a je jedno, jestli je to na Windows či linuxu) SMAZAT již nadefinovaný profil pro připojení k Exchange 2010
  7. V poštovním IMAP programu nakonfigurovat nově profil pro připojení k Exchange 2010.

Po provedení těchto kroků pro každou e-mailovou složku, která se nesynchronizuje korektně, se začnou příchozí e-maily zobrazovat v pořádku.

Tak nad výše uvedeným jsem strávil pořádný počet hodin. Velice mi pomohly odkazy zde a zde. A teď infarktový závěr dnešního dne – před pár minutami vydal Microsoft Rollup Update 2 for Exchange Server 2010, který uvedený problém řeší :)

KB 979480 IMAPid was not working correctly after moving a lot of users from one Exchange 2010 server to another*. IMAP4 users complained about the inbox not being updated any more. Old messages were still visible, but messages which were received after the mailbox move were not visible. The problem affected different IMAP Clients. The problem did not affect MAPI clients and OWA. Now it is fixed up. *(Specifically this occurred in the situation with same DAG, now local storage instead of iSCSI storage, all servers are Exchange 2010 with Update Rollup 1 installed on Windows Server 2008 R2).

Pro tisk
Komentáře jsou uzavřeny